WAS7 – Busines level Application can not be removed

In WAs7, IBM introduced the new concept BLA (business level application) which can include EAR, JAR or share libraries.

However, some times when you update a EAR file from console but failed, which cause the Enterprise Application was removed but BLA was still left. When you redeploy the same module, the module can not be deployed, and you will see the following error when you want to delete the existing BLA:

CWWMH0149E: Cannot delete business-level application “WebSphere:blaname=AppEAR” because it contains composition units. Delete all composition units which belong to the business-level application, and then delete the business-level application. Check log for details.

As a matter of fact, you already removed all composition units, and you can not see any composition units belong to this BLA from administrative console or even using wsadmin scripts.

Here is a way for how to remove the isolated BLA if BLA can not be removed without any composition units belonging to it.

1) stop the WebSphere Application Server.

2) backup the WebSphere profile configuration using “backupConfig.sh” command

3) go to directory <ProfileDir>/config/cells/<CellName>/blas

4) remove the directory of specified BLA

5) go to directory <ProfileDir>/config/cells/<CellName>/cus

6) remove the directory of specified BLA

7) go to directory <ProfileDir>config, remove temp directory

8) go to directory <ProfileDir>, remove wstemp and temp directory

9) restart the WebSphere Application Server

10) redeploy the module.

this is the way I solved this problem. I hope someone can provide the better way to solve this issue.

Advertisements

About this entry